Problems

Problems for v. 2.x

libz.so

When running app crushed with error:

libz.so: cannot open shared objet files: No such file or directory

It is bug https://github.com/AppImage/AppImageKit/issues/1092

Install libz into you distr. For Ubuntu 20.01:

$ sudo apt install zlib1g-dev

Problems for v. 1.x

libnss3.so

KioskBrowser error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory

On Gentoo or Calculate Linux run:

$ emerge dev-libs/nss

If not work, try:

$ revdep-rebuild --library libnss3.so

libatomic.so

FATAL:nw_content_renderer_hooks.cc(53)] Failed to load node library (error: libatomic.so.1 …

You need install libatomic.

For CentOS is:

# dnf install libatomic